Email notifications
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 10:02 EST
Identified
We are aware of some issues with email notifications and are investigating the problem
Posted Aug 04, 2023 - 05:58 EDT
This incident affected: Notifications.