Login error
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 13:20 EST
Identified
Logins are failing the authentication step. We are working on a fix and will keep this page updated.
Posted Nov 22, 2019 - 08:53 EST
This incident affected: Web Client.