Web Client is broken. We are working on a fix.
Incident Report for CrowdTangle
Resolved
Our web client went down for 25minutes, but we are back up!
Posted 5 months ago. Dec 17, 2018 - 20:50 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Dec 17, 2018 - 20:35 EST
This incident affected: Web Client.