Unable to add new accounts to the lists in CrowdTangle
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 14:00 EDT
Investigating
We are investigating an issue where our users are unable to add new accounts to lists.

Thank you for your patience as we work to fix it!
Posted Jun 02, 2023 - 09:00 EDT
This incident affected: Web Client.