Service Interrupted
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 24, 2019 - 09:17 EDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jun 24, 2019 - 09:16 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 24, 2019 - 09:15 EDT
This incident affected: Web Client, Notifications, Search, and API.