Search is very slow (including the Chrome Extension)
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 13:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 23, 2019 - 12:16 EDT
This incident affected: Search.