Live Displays are currently not loading!
Incident Report for CrowdTangle
Resolved
This is solved!
Posted Oct 16, 2020 - 15:27 EDT
Identified
Most users will receive a blank screen. Working on a fix now!
Posted Oct 16, 2020 - 14:51 EDT
This incident affected: Web Client.