Unable to update data in Lists and Search in CrowdTangle
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 02:08 EDT
Investigating
We know that users are experiencing problems with Facebook lists and keyword searches for pages. Thank you for your patience as we work to fix it
Posted Jun 25, 2024 - 17:32 EDT