Web client is completely down, cannot be visited.
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted 7 months ago. Nov 02, 2018 - 05:47 EDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Nov 02, 2018 - 05:32 EDT
This incident affected: Web Client.