Many Live Displays are failing or showing the wrong timeframe.
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 14, 2019 - 12:35 EDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jun 14, 2019 - 09:47 EDT
Monitoring
This incident has been resolved.
Posted 3 months ago. Jun 14, 2019 - 09:46 EDT
This incident affected: Web Client.