Site is down
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 20:53 EST
Identified
We expect it to be back within a minute or so
Posted Feb 28, 2020 - 20:48 EST
This incident affected: Web Client, Notifications, Search, API, and Chrome Extension.