Chrome Extension Down
Incident Report for CrowdTangle
Resolved
This incident has been resolved.
Posted 24 days ago. Aug 27, 2019 - 10:13 EDT
Investigating
We are currently investigating this issue.
Posted 24 days ago. Aug 27, 2019 - 09:00 EDT
This incident affected: Chrome Extension.